Error Codes: E2 (Inflation Error)

What does Error Code E2 mean?

Error Code E2 means your Sleep Number® smart bed is taking longer than expected to inflate between Sleep Number® settings. This usually happens when an air hose connection is loose, kinked, or partially disconnected.
 
In most cases, you can resolve this issue by checking the air hoses at the mattress and pump.
 
 

Common Causes

  • Loose hose connection between the pump and air chamber
  • Kinked or twisted air hose
  • Damaged hose connector or tab
  • Air chamber not fully connected
 

How to Fix Error Code E2

Step 1: Check air chamber hose connections

Note: In some configurations, air hoses will come out of the top of the mattress instead of the side.

  1. Lift the side of the mattress near the Favorite button location.
  2. Reach into the slit on the underside of the mattress.
  3. Confirm the hose is firmly connected to the air chamber.
  4. If needed, disconnect the hose by pressing the tab and gently pulling.
  5. Inspect the connector:
    • Tab is not broken
    • No cracks in tubing
    • Two black O‑rings are present
  6. Reconnect the hose until it snaps into place.
  7. Feed any excess hose back into the base (if applicable).
  8. Repeat on the other side for dual‑chamber beds.

Step 1: Check air chamber hose connections

 

Step 2: Restart the bed

  1. Unplug the bed for 20 seconds.
  2. Plug the bed back in.
  3. Test your Sleep Number® setting again.
If the mattress was very flat, inflation can take up to 15 minutes.

 

Step 3: Check pump connections

  1. Locate the pump at the foot of the bed inside the base.
  2. Disconnect the hose by pressing the tab and gently pulling.
  3. Inspect the connector:
    • Blue or white tab is intact
    • No visible damage
  4. Reconnect the hose securely.

Step 3: Check pump connections

 

Step 4: If the issue continues

If you continue to experience issues, perform air loss troubleshooting.
If you find damaged or broken parts, contact Sleep Number Customer Support for replacement components.

Call Customer Support

Mon - Fri: 8AM - 4:30PM CT, Saturday: 10AM - 2PM CT

Call 1-800-472-7185

Chat Support

Available 7 days a week: 6AM - 11 PM CT

Click/tap the "Chat" icon in the lower right corner of your device screen.

 

Frequently Asked Questions

How long should a Sleep Number® bed take to inflate?

Inflation time varies. If the mattress is very flat, it can take up to 15 minutes to fully inflate.
 
 

Where are the air hose connections located?

Depending on your model, hose connections are located at the head of the bed or along each side of the base
 
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